Delgine 3D Tools & Content DeleD Community Edition
Forums
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

DeleD 2.45

 
Post new topic   Reply to topic    DeleD Community Edition Forum Index -> DeleD Bugs
View previous topic :: View next topic  
Author Message
MadMikeAU
Member


Joined: 18 Apr 2011
Posts: 38
Location: West Sydney, NSW, Australia

PostPosted: Wed Apr 27, 2011 1:28 am    Post subject: DeleD 2.45 Reply with quote

The other day, I made a tutorial for making eyes. (Need access to the wiki to upload, BTW)...and noticed a few things...

1) Edge mode: Scale works but the Scale Properties dialog doesn't do anything.

2) Transparency does not affect the 3D view.

3) .X exporter doesn't export transparency.

Also...
4) When a primitive is assigned to a skeleton, it no longer appears in the scene navigator. This is frustrating as to make even a minor change (say to UV or material), you have to unassign it from the skeleton, make the change then reassign it, then reassign each joint, etc, etc.

5) (Feature request) Bone weights. At the moment, vertices are assigned to one joint only.
Back to top
View user's profile Send private message Visit poster's website
adr
Member


Joined: 23 Jul 2005
Posts: 165

PostPosted: Wed Apr 27, 2011 6:38 am    Post subject: Reply with quote

1) Doesn't work for me either.

2) Still works for me in the 3D view.

3) Mine still exported transparency.

4 and up) The skeleton feature is still new and still needs a lot of work. That is one of the issues with it right now. Along with it not being able to be saved out into a .x. Also the reason why you don't see a lot of people using it.... With a lot of people not using it right now, the feature has been on the lower pir.... I think once it starts having a few issues fixs, it'll be one of the most used features of Deled...
Back to top
View user's profile Send private message Yahoo Messenger
Jeroen
Site Admin


Joined: 07 Aug 2004
Posts: 5321
Location: The Netherlands

PostPosted: Wed Apr 27, 2011 7:18 am    Post subject: Reply with quote

About the wiki account: see this topic. Smile

1. Yep, that's a bug right there. Community, fix this! Very Happy

2. Indeed, as adr says, it should still work. What have you tried to get this working for you?

3. Don't know about that really, sorry. I have no real experience with transparency in DeleD in general.

4. Is by design because it saved me from having to implement a lot more administrative code to make sure everything is in sync after making changes to primitives that are also assigned to skeletons. I realize this is not the most user-friendly approach and encourage anyone to improve on this.

5. That's indeed a very nice request. I don't have enough time to implement such a thing (it's not a simple bugfix Wink) but am more than willing to assist anyone who wants to give it a try.

About the animation system... if bone weights are implemented, would that really make DeleD much more attractive as animation modeller, as adr says?
_________________
Check out the gallery, our DeleD Wiki and Youtube videos!
Back to top
View user's profile Send private message Send e-mail Visit poster's website
MadMikeAU
Member


Joined: 18 Apr 2011
Posts: 38
Location: West Sydney, NSW, Australia

PostPosted: Wed Apr 27, 2011 8:27 am    Post subject: Reply with quote

Thanks for the replies.

Rereading this, I can see that 2) and 3) are probably related. I set the transparency in the material editor. hmmm...maybe I am screwing that up...i'll try again and report back.

I think adr is referring to the fact that DeleD's exporters not exporting animations (except Milkshape that I recently added animations to, of course).

And I know 5 is a big undertaking Laughing but if you don't put it out there....
Back to top
View user's profile Send private message Visit poster's website
MadMikeAU
Member


Joined: 18 Apr 2011
Posts: 38
Location: West Sydney, NSW, Australia

PostPosted: Wed Apr 27, 2011 9:03 am    Post subject: Reply with quote

Regarding (2)...I only get transparency if I set the blend mode to Modulate.
Back to top
View user's profile Send private message Visit poster's website
adr
Member


Joined: 23 Jul 2005
Posts: 165

PostPosted: Wed Apr 27, 2011 10:49 pm    Post subject: Reply with quote

Quote:
About the animation system... if bone weights are implemented, would that really make DeleD much more attractive as animation modeller, as adr says?


I would have to say yes, but we needs to fixs the issue that is slowing down the call for this type of feature. I remember when it first came out and everyone wanted a little more and more from the animation modeller. As the animation modeller never got support from the plugins, a lot of people stop using it. I know we, as the cummunity, needs to fixs this, but until that happens, no one is going to say, "I want that."

What came first? The chicken or the egg sort of idea thinking.

Talking about it here doesn't help either ^^;

2) I know silly questions, but may help find the answer. Are you using a type of exc that supports the channel such as a .png? Are you sure that this type of file has transparency in it?

3) Are you setting your texture to Modulate and then saving it out? If so, I'm not sure if that'll save out as a transparency texture. (I just check... using the .x exported doesn't save the images as .png or some type of channel handling image.) This could be said as a bug.
Back to top
View user's profile Send private message Yahoo Messenger
MadMikeAU
Member


Joined: 18 Apr 2011
Posts: 38
Location: West Sydney, NSW, Australia

PostPosted: Thu Apr 28, 2011 12:13 am    Post subject: Reply with quote

adr:
1) As I said before, the M3D exporter now exports animations. I have started work on a FBX exporter, but no promises on the speed of success there Wink

2) + 3) I am using the color option instead of a texture. You can set a transparency level at the material level, so the contents of the texture is implied to be irrelevant.
Back to top
View user's profile Send private message Visit poster's website
AWM Mars
Member


Joined: 06 Jan 2010
Posts: 1193
Location: Wilts England

PostPosted: Thu Apr 28, 2011 10:17 pm    Post subject: Reply with quote

I posted some of the features I use with transparencies here http://www.delgine.com/forum/viewtopic.php?t=4393 using both png32, set to Alphablend and also the material colouring on the vertices's.

Further work was exhibited here http://www.delgine.com/forum/viewtopic.php?t=4188&postdays=0&postorder=asc&start=90

Took me a while to work out how much of this stuff works, but what does work, works well Very Happy

Hope this works to help inspire you as much as it did me.
_________________
Politeness is priceless when received, cost nothing to own or give, yet some cannot afford.

Checkout:
http://www.awm.mars.yourinside.com/
http://www.bccservices.co.uk
http://www.localtradecheck.co.uk
Back to top
View user's profile Send private message Visit poster's website
MadMikeAU
Member


Joined: 18 Apr 2011
Posts: 38
Location: West Sydney, NSW, Australia

PostPosted: Fri Apr 29, 2011 1:04 am    Post subject: Reply with quote

ok. I got it working with alphablend. When I set the color, it has an alpha value in the color picker....and the transparency slider does nothing, apparently. Thats OK. Thanks, AWM Mars.
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    DeleD Community Edition Forum Index -> DeleD Bugs All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum