Delgine 3D Tools & Content DeleD Community Edition
Forums
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Strange plugin parse error

 
Post new topic   Reply to topic    DeleD Community Edition Forum Index -> DeleD Plugins
View previous topic :: View next topic  
Author Message
Mr.Fletcher
DeleD PRO user


Joined: 07 Aug 2004
Posts: 1772
Location: Germany

PostPosted: Sun Jun 17, 2007 1:04 pm    Post subject: Strange plugin parse error Reply with quote

Hello guys,

I'm currently developing a plugin and encountered a very, very strange error. I have a lightmapped scene with two flowers. Everything is normal, the scene file, too. When I request the scene from DeleD though, for one lightmap layer, I get 'FFFFFFFF' where the lightmap file path was supposed to be. Lightmapping it again does not change anything.
I uploaded the scene file and the XML data I received from DeleD (responseXML.dxs). The FFs are in responseXML.dxs, but not in flowers.dxs.

Please prove my sanity and tell me you experience the same thing.

Get the files here.

//edit
Okay, now I'm confused. It seems to work now, I don't get the FFs anymore. We'll see...
_________________
Behold! The DeleD Wiki! Please help us expanding it Smile
DeleD on IRC
Back to top
View user's profile Send private message
Jeroen
Site Admin


Joined: 07 Aug 2004
Posts: 5334
Location: The Netherlands

PostPosted: Sun Jun 17, 2007 8:18 pm    Post subject: Reply with quote

Topic moved to Plugins forum.
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Paul-Jan
Site Admin


Joined: 08 Aug 2004
Posts: 3066
Location: Lage Zwaluwe

PostPosted: Mon Jun 18, 2007 6:56 pm    Post subject: Reply with quote

Could this be the result of something like
1. Lightmap
2. Rename scene (without regenerating lightmaps)
3. Export

?

There is a mechanism that replaces lightmap textures with $FFFFFFFF (white, full alpha) colored textures when the actual files are not found. This kinda smells like it is related, although I can't figure out exactly why or how.
Back to top
View user's profile Send private message Visit poster's website
Mr.Fletcher
DeleD PRO user


Joined: 07 Aug 2004
Posts: 1772
Location: Germany

PostPosted: Mon Jun 18, 2007 8:55 pm    Post subject: Reply with quote

I neither renamed the scene nor exported it, but I did lightmap it. The FF were there several times when I tried it, also after restarting DeleD but then they disappered without that I did something differently. I had this with another scene, too, but only once and actually did not do anything for it, then.
I guess I'll observe these things...
_________________
Behold! The DeleD Wiki! Please help us expanding it Smile
DeleD on IRC
Back to top
View user's profile Send private message
Paul-Jan
Site Admin


Joined: 08 Aug 2004
Posts: 3066
Location: Lage Zwaluwe

PostPosted: Tue Jun 19, 2007 7:14 pm    Post subject: Reply with quote

Same here, we'll keep an eye open!
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    DeleD Community Edition Forum Index -> DeleD Plugins All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum