Delgine 3D Tools & Content DeleD Community Edition
Forums
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

New Plug-in: Levelwalker -- now with Collision!
Goto page Previous  1, 2, 3  Next
 
Post new topic   Reply to topic    DeleD Community Edition Forum Index -> DeleD Plugins
View previous topic :: View next topic  
Author Message
jwatte
DeleD PRO user


Joined: 26 Apr 2006
Posts: 513

PostPosted: Tue Sep 25, 2007 5:55 am    Post subject: Reply with quote

For everyone in the thread:

I've updated to version 2007-09-24c. This version solves the following problems:

- much improved walking and controls
- F to turn off gravity; G to turn it on
- much improved performance on scenes with large textures
- possible fix for crash on ATI cards
- doesn't need the vcredist installer in release builds

Note that the lm5 scene (German castle) uses about 75 MB of textures. When all textures are in view, a 64 MB graphics card will run pretty slowly. The only real solution is to do a portal scene manager, which DeleD doesn't construct for you.
Back to top
View user's profile Send private message
Mr.Fletcher
DeleD PRO user


Joined: 07 Aug 2004
Posts: 1772
Location: Germany

PostPosted: Tue Sep 25, 2007 10:18 am    Post subject: Reply with quote

I get a lot of these when I try to load the castle now.


After about 30 of these, DeleD itself crashs.

Also, I think the friction of the player body is too low, you keep sliding a significant distance once you release the movement buttons.

And gravity behaves weird with different unit measures. I loaded a level in which the player is 8 units high and gravity was way too low. Then, I tried it on another level with 500 units player height and gravity was too high.
_________________
Behold! The DeleD Wiki! Please help us expanding it Smile
DeleD on IRC
Back to top
View user's profile Send private message
jwatte
DeleD PRO user


Joined: 26 Apr 2006
Posts: 513

PostPosted: Tue Sep 25, 2007 4:12 pm    Post subject: Reply with quote

Interesting. Doesn't happen on my NVIDIA. As the crash is in nvoglnt.dll, it's a driver issue. I just don't do anything tricky, though... What version of the NVidia driver are you using? What card?
Back to top
View user's profile Send private message
Mr.Fletcher
DeleD PRO user


Joined: 07 Aug 2004
Posts: 1772
Location: Germany

PostPosted: Tue Sep 25, 2007 4:37 pm    Post subject: Reply with quote

Well how do I look that up? ^^
Here is what I found:



I'll try updating the drivers.
_________________
Behold! The DeleD Wiki! Please help us expanding it Smile
DeleD on IRC
Back to top
View user's profile Send private message
jwatte
DeleD PRO user


Joined: 26 Apr 2006
Posts: 513

PostPosted: Tue Sep 25, 2007 9:12 pm    Post subject: Reply with quote

Wow, someone with an older driver than mine! I'm running 84.91 (the laptop problem, where I can't update using regular drivers). Let me know if it works better after updating.
Back to top
View user's profile Send private message
Starnick
DeleD PRO user


Joined: 28 Jul 2007
Posts: 611

PostPosted: Tue Sep 25, 2007 9:51 pm    Post subject: Reply with quote

Still no dice on my end with the ATI radeon card.
Back to top
View user's profile Send private message Visit poster's website AIM Address
Mr.Fletcher
DeleD PRO user


Joined: 07 Aug 2004
Posts: 1772
Location: Germany

PostPosted: Tue Sep 25, 2007 9:51 pm    Post subject: Reply with quote

Yeah, works now. However, the loading time still is very high. Also, once it's loaded, something still seems to load there, until it runs fluently. But then, when you turn to another direction, it still loads for 30 seconds with a frame rate of 0.5. After that, it's fine but once to turn again it starts all over :/
_________________
Behold! The DeleD Wiki! Please help us expanding it Smile
DeleD on IRC
Back to top
View user's profile Send private message
jwatte
DeleD PRO user


Joined: 26 Apr 2006
Posts: 513

PostPosted: Wed Sep 26, 2007 12:50 am    Post subject: Reply with quote

Starnick wrote:
Still no dice on my end with the ATI radeon card.


Do you get any kind of alert, or just the "read of address 00000000" error?
Back to top
View user's profile Send private message
jwatte
DeleD PRO user


Joined: 26 Apr 2006
Posts: 513

PostPosted: Wed Sep 26, 2007 12:57 am    Post subject: Reply with quote

Mr.Fletcher wrote:
it still loads for 30 seconds with a frame rate of 0.5


The main problem I've seen is that the scene uses 75 MB of textures when light mapped! If your card has "turbo cache" which means it has some small amount of RAM on the chip, and then uses main RAM for the rest, then this will run slowly when seeing all those textures as new. It does on my 7400, for sure!

Hmm, come to think of it, I wonder if I'm turning on automatic MIP map filtering... If not, then that would also cause sluggish performance.
Back to top
View user's profile Send private message
jwatte
DeleD PRO user


Joined: 26 Apr 2006
Posts: 513

PostPosted: Wed Sep 26, 2007 12:59 am    Post subject: Reply with quote

Hmm. MIP generation and filtering is certainly on, so that's not it.
Back to top
View user's profile Send private message
Starnick
DeleD PRO user


Joined: 28 Jul 2007
Posts: 611

PostPosted: Wed Sep 26, 2007 2:30 pm    Post subject: Reply with quote

jwatte wrote:
Starnick wrote:
Still no dice on my end with the ATI radeon card.


Do you get any kind of alert, or just the "read of address 00000000" error?


Just the read address error so far
Back to top
View user's profile Send private message Visit poster's website AIM Address
jwatte
DeleD PRO user


Joined: 26 Apr 2006
Posts: 513

PostPosted: Wed Sep 26, 2007 8:42 pm    Post subject: Reply with quote

If you are having levelwalker problems, can you try this new version? It will write a minidump to disk if you crash, which may help me figuring out the problem.
Also, I've made some minor load time performance improvements.

http://levelwalker.googlecode.com/files/levelwalker-2007-09-26a.zip
Back to top
View user's profile Send private message
Starnick
DeleD PRO user


Joined: 28 Jul 2007
Posts: 611

PostPosted: Thu Sep 27, 2007 2:59 am    Post subject: Reply with quote

Well it didn't crash out of the program nor give me a headache full of pop-ups...just one nice little error that let me continue using deled - at least that was nice Very Happy

Dump file can be downloaded here:

http://www.mediafire.com/?5bgz9yytxyb
Back to top
View user's profile Send private message Visit poster's website AIM Address
jwatte
DeleD PRO user


Joined: 26 Apr 2006
Posts: 513

PostPosted: Thu Sep 27, 2007 5:46 am    Post subject: Reply with quote

Yeah, I made it close when it detected a crash. I figured that was better than the alternative :-)

Anyway, thanks a lot for that minidump file! I believe I know how the ATI driver is provoking that crash, and think I might have fixed it. I can't test myself, though. I have uploaded a new debug version:

http://levelwalker.googlecode.com/files/levelwalker-2007-09-26b.zip

Note that this version will be slower to start up than the release version, as it's built without optimization. If it works, I'll re-build a release version and release as 1.0.

Btw: Fletcher, I think this version fixes the slowness with large textures on cards with too little VRAM. There will still be small pauses when doing quick turns, but at least it'll run smooth once you've made that turn. Could you try it too?
Back to top
View user's profile Send private message
Mr.Fletcher
DeleD PRO user


Joined: 07 Aug 2004
Posts: 1772
Location: Germany

PostPosted: Thu Sep 27, 2007 10:41 am    Post subject: Reply with quote

Now, it doesn't show up in the plugin menu again Sad
_________________
Behold! The DeleD Wiki! Please help us expanding it Smile
DeleD on IRC
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    DeleD Community Edition Forum Index -> DeleD Plugins All times are GMT
Goto page Previous  1, 2, 3  Next
Page 2 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum