Delgine 3D Tools & Content DeleD Community Edition
Forums
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

NashaUV - UV Editor plugin for DeleD (beta)
Goto page 1, 2, 3  Next
 
Post new topic   Reply to topic    DeleD Community Edition Forum Index -> DeleD Plugins
View previous topic :: View next topic  
Author Message
chronozphere
DeleD PRO user


Joined: 20 Jun 2006
Posts: 1010
Location: Netherlands

PostPosted: Sat Jul 04, 2009 2:06 pm    Post subject: NashaUV - UV Editor plugin for DeleD (beta) Reply with quote

Hey guys

I've been working on this plugin for a few months, because I thought DeleD needed some proper UV-editing tools. In my opinion, UV-mapping is a very tedious job in the current version of DeleD. That's why I made this plugin. I think it's time to show it to you. It's far from finished, but it is usable. Very Happy

Features:
> An UV and a 3D viewport for a WYSIWYG UV-mapping experience
> Vertex, Edge and Polygon mode
> Move, Rotate and Scale tool
> Snap-To-Grid and "Angular snapping" (for rotation)
> Elements are highlighted simultaniously in both viewports when you move your mouse over them
> Click- and Drag-Selection supported in both views
> Backface culling (for selecting and rendering)
> Texture in background in UV-View

Things I want to implement
> A free 3d camera (the current one always looks at the origin)
> Align/Mirror/Weld tools
> Planar/Cylindrical/Spherical texture mapping
> A "preferences" window

Known issues
> NashaUV is not a high-performance tool. If you load objects/scenes with a few thousands of vertices, It might get a little too slow.
Seperate your scene in objects and texture them one by one.
> NashaUV expects "proper" geometry. Only non-intersecting convex polygons must be used. Delete any redundant vertices before texturing.
> Because I use OpenGL picking for selections, the plugin might not work properly on some systems, due to crappy driver-implementations. I can't fix this, sorry!
> The "options" toolbutton is there, but it doesn't work (yet).
> Only the vertex, edge and polygon mode work. The mapping modes don't work yet.
> If you don't see any UV-coordinates, use boxmapping first before firing up the plugin. Smile

To download NashaUV, click here:

Download

Just unzip it and dump it in the Plugins directory. Smile
I hope the archive is not damaged.

How to use:
Moving the camera and selecting works very similair to DeleD. There are a few differences:
> Shift + Ctrl + Click/Drag adds elements to the selection while Shift + Alt+ Click/Drag removes elements from the selection.
> The 3d camera always looks at the origin
> Use the top-left toolbutton to change the current edit mode.
> "Culling" (check statusbar) also has an effect on drag-selecting in 3d-view. With culling enabled, only the visible faces will be selected.
> Doubleclick the "NO TEXTURE" text in the statusbar to make the texture visible as background in UV-view.
> Click the "floppy" icon to save the changes to DeleD.

Some screenshots:






Unfortunately I don't have much time to work on this project. I'm going on two holiday's and I want to join the PGD competition. Nevertheless, I'll try to keep working on it and add the features on my wishlist.

Any comments/questions/bug-reports are welcome. Wink
Hope you like it.

chronozphere


Last edited by chronozphere on Fri Oct 23, 2009 4:51 pm; edited 4 times in total
Back to top
View user's profile Send private message
trucker2000
DeleD PRO user


Joined: 11 May 2005
Posts: 1839
Location: Sacramento, California

PostPosted: Sat Jul 04, 2009 5:52 pm    Post subject: Reply with quote

I got a bad block error message when I unzipped, and this doesn't show up in the pluggins.
_________________
Some day I will grow up and be a real modeler.
"Never give up! Never surrender!!"
Sys specs:
asus
8 gigs ram
Invidia gtx560 video card
Windows 8 (worst op sys Ever)
Back to top
View user's profile Send private message Visit poster's website
chronozphere
DeleD PRO user


Joined: 20 Jun 2006
Posts: 1010
Location: Netherlands

PostPosted: Sat Jul 04, 2009 6:48 pm    Post subject: Reply with quote

Okay... I've now uploaded a ZIP instead of a RAR. Can you try again?

Ofcourse, unzip it first and put the DLL in the plugins/ directory. Smile
Back to top
View user's profile Send private message
trucker2000
DeleD PRO user


Joined: 11 May 2005
Posts: 1839
Location: Sacramento, California

PostPosted: Sat Jul 04, 2009 7:49 pm    Post subject: Reply with quote

That worked. I'll have to play with it for a bit to learn it, but in just a few seconds I was moving my UVs around. Thankyou for this. Smile
_________________
Some day I will grow up and be a real modeler.
"Never give up! Never surrender!!"
Sys specs:
asus
8 gigs ram
Invidia gtx560 video card
Windows 8 (worst op sys Ever)
Back to top
View user's profile Send private message Visit poster's website
fik
Member


Joined: 11 Oct 2006
Posts: 303

PostPosted: Sat Jul 04, 2009 9:23 pm    Post subject: Reply with quote

This looks really interesting will download and have a go with. Hope you do get time to keep working on this however slowly Smile
Back to top
View user's profile Send private message
paul_nicholls
DeleD PRO user


Joined: 05 Dec 2007
Posts: 356
Location: Hobart, Tasmania, Australia

PostPosted: Sun Jul 05, 2009 11:14 am    Post subject: Reply with quote

It's great news to hear that you have something to show for your DeleD UV editor plugin!

Great job! Smile
cheers,
Paul
_________________
Long live DeleD!

Hi ho...hi ho...it's off 3d modeling I go...
Back to top
View user's profile Send private message
paul_nicholls
DeleD PRO user


Joined: 05 Dec 2007
Posts: 356
Location: Hobart, Tasmania, Australia

PostPosted: Tue Sep 08, 2009 6:20 am    Post subject: Reply with quote

Hi chronozphere...I downloaded your UV plugin and am trying it out...

I did notice one thing - when pressing the floppy disc to save, I get this dialog box error (obviously due to hard coded paths in code):

Code:
---------------------------
deled
---------------------------
Cannot create file "E:\test.xml". Access is denied.
---------------------------
OK   
---------------------------


Besides that, nice job so far Smile

cheers,
Paul
_________________
Long live DeleD!

Hi ho...hi ho...it's off 3d modeling I go...
Back to top
View user's profile Send private message
chronozphere
DeleD PRO user


Joined: 20 Jun 2006
Posts: 1010
Location: Netherlands

PostPosted: Tue Sep 08, 2009 6:37 pm    Post subject: Reply with quote

Oops... I probably left that in my code for debugging purposes. Need to get rid of that. Embarassed

EDIT:

Here is a newer version that doesn't have the "E:/test.xml" problem. It also has a new mirror tool. Very Happy

Download the archive here!!

Hope I find some time to work on this. I just started at university, so I'm very busy ATM. Sad
Back to top
View user's profile Send private message
chronozphere
DeleD PRO user


Joined: 20 Jun 2006
Posts: 1010
Location: Netherlands

PostPosted: Fri Oct 23, 2009 4:52 pm    Post subject: Reply with quote

Okay... Update:

Changes:
* a freely movable camera Razz
* some bug-fixes, AV's and such

The link in the startpost also points to the latest version, but here it is anyway:

Download

And another screenshot:



Is anyone using my plugin? Confused
Please, give it a shot. I use it all the time. Smile
Back to top
View user's profile Send private message
nono
Member


Joined: 26 Sep 2009
Posts: 12

PostPosted: Fri Oct 23, 2009 6:01 pm    Post subject: Reply with quote

thank's for your work, i download it and i will test next week end Wink (this one is my wife birthday, so no computer Laughing )
_________________
Deled pro user since january 2008
but still a beginner
Back to top
View user's profile Send private message
harper
Member


Joined: 19 Jul 2007
Posts: 283
Location: Hamburg, Germany

PostPosted: Fri Oct 23, 2009 7:38 pm    Post subject: Reply with quote

One question, Chrono:
Will Your Plugin overwrite the original uv-mapping from DeleD or am i free to use both? I'm soo familiar with the inbuilt one,
so i don't want to miss it.
Back to top
View user's profile Send private message Visit poster's website
Mr.Fletcher
DeleD PRO user


Joined: 07 Aug 2004
Posts: 1772
Location: Germany

PostPosted: Fri Oct 23, 2009 7:50 pm    Post subject: Reply with quote

It doesn't override the built in one if it's used as a plugin. It just adds its functionality.
_________________
Behold! The DeleD Wiki! Please help us expanding it Smile
DeleD on IRC
Back to top
View user's profile Send private message
Jeroen
Site Admin


Joined: 07 Aug 2004
Posts: 5334
Location: The Netherlands

PostPosted: Sat Oct 24, 2009 3:40 pm    Post subject: Reply with quote

I'll include this version with the next version of DeleD (2.3).

I did notice something strange though. The first time I start a fresh install of DeleD and run the plugin, the plugin says the TextureDirectory is invalid. Restarting DeleD and running the plugin again and things work as expected. Also, the filename mentiones 0.56 as version number but the plugin says it's 0.46. Something you want to take a look at?
_________________
Check out Figuro, our online 3D app! More powerful 3D tools for free.
Back to top
View user's profile Send private message Send e-mail Visit poster's website
chronozphere
DeleD PRO user


Joined: 20 Jun 2006
Posts: 1010
Location: Netherlands

PostPosted: Sat Oct 24, 2009 6:11 pm    Post subject: Reply with quote

Yeah.. I'll take a look at those issues ASAP. Thanks for reporting them. Smile

Edit: Ok, the version number issue is fixed, but that's not worth a new upload lol. Cool
The plugin reads the texture directory from the INI file. However, when DeleD starts for the first time, these paths are not initialized in the INI. The [dirs] section is empty. I'm not sure whether I should work around this or not? Maybe you can put the correct paths there, so that all plugins can rely on the INI file. Any other suggestions?
Back to top
View user's profile Send private message
Jeroen
Site Admin


Joined: 07 Aug 2004
Posts: 5334
Location: The Netherlands

PostPosted: Sat Oct 24, 2009 6:26 pm    Post subject: Reply with quote

Ah, ok then. Minor issue, I think, as this only happens when using plugins the first time DeleD is being run after installing it. I think you should not work around this in the plugin.
_________________
Check out Figuro, our online 3D app! More powerful 3D tools for free.
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    DeleD Community Edition Forum Index -> DeleD Plugins All times are GMT
Goto page 1, 2, 3  Next
Page 1 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum